Project

General

Profile

Bug #5700

erlang-hipe

Added by Edward Nichols about 2 years ago. Updated about 1 year ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
06/09/2016
Due date:
% Done:

0%

Estimated time:
Affected versions:

Description

I am unable to get hipe to work via the erlang-hipe package.

Erlang/OTP 18 [erts-7.3.1] [source] [64-bit] [smp:8:8] [async-threads:10] [kernel-poll:false]

Even after erlang-hipe is installed.

History

#1 Updated by Gabriele Santomaggio over 1 year ago

Edward Nichols wrote:

I am unable to get hipe to work via the erlang-hipe package.

Erlang/OTP 18 [erts-7.3.1] [source] [64-bit] [smp:8:8] [async-threads:10] [kernel-poll:false]

Even after erlang-hipe is installed.

by removing --disable-hipe flag(https://git.alpinelinux.org/cgit/aports/tree/community/erlang/APKBUILD#n89) , the HIPE module seems to work correctly.

alpine:~/erlang$ erl
-ash: erl: not found
alpine:~/erlang$ sudo apk add --allow-untrusted /home/gb/packages/gb/x86_64/erlang-hipe-19.1.0-r3.apk
(1/5) Installing erlang-kernel (19.1.0-r3)
(2/5) Installing erlang-stdlib (19.1.0-r3)
(3/5) Installing erlang-compiler (19.1.0-r3)
(4/5) Installing erlang (19.1.0-r3)
(5/5) Installing erlang-hipe (19.1.0-r3)
Executing busybox-1.26.2-r1.trigger
OK: 902 MiB in 169 packages
alpine:~/erlang$ erl
Erlang/OTP 19 [erts-8.1] [source] [64-bit] [async-threads:10] [kernel-poll:false]

Eshell V8.1 (abort with ^G)
1> l(hipe). {module,hipe}
2>

#2 Updated by Jens Koehler about 1 year ago

I wonder what's the point of erlang-hipe when it's disabled in erlang (which is a dependency)?

#3 Updated by Gabriele Santomaggio about 1 year ago

Fixed here https://github.com/alpinelinux/aports/pull/1916
I think we can close the issue.

#4 Updated by Jens Koehler about 1 year ago

Gabriele Santomaggio wrote:

Fixed here https://github.com/alpinelinux/aports/pull/1916
I think we can close the issue.

Doesn't seem to work for me. Even when switching to edge (for downloading erlang with version 19.3.0-r4) I'm still getting "{error,nofile}" when running "l(hipe)."

#5 Updated by Gabriele Santomaggio about 1 year ago

Jens Koehler wrote:

Gabriele Santomaggio wrote:

Fixed here https://github.com/alpinelinux/aports/pull/1916
I think we can close the issue.

Doesn't seem to work for me. Even when switching to edge (for downloading erlang with version 19.3.0-r4) I'm still getting "{error,nofile}" when running "l(hipe)."

yes you are right, I left a comment here: https://github.com/alpinelinux/aports/pull/1916#issuecomment-317655109

Also available in: Atom PDF