Project

General

Profile

Bug #9093

Bug #9091: phpmyadmin: Multiple vulnerabilities (CVE-2018-12581, CVE-2018-12613)

[3.8] phpmyadmin: Multiple vulnerabilities (CVE-2018-12581, CVE-2018-12613)

Added by Alicha CH 6 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Security
Target version:
Start date:
07/16/2018
Due date:
% Done:

100%

Estimated time:
Affected versions:
Security IDs:

Description

CVE-2018-12581: XSS in Designer feature

A Cross-Site Scripting vulnerability was found in the Designer feature, where an attacker can
deliver a payload to a user through a specially-crafted database name.

Affected Versions:

phpMyAdmin versions prior to 4.8.2.

Reference:

https://www.phpmyadmin.net/security/PMASA-2018-3/

Patch:

https://github.com/phpmyadmin/phpmyadmin/commit/6943fff87324bd54c3a37a5160a5fb77498c355e

CVE-2018-12613: File inclusion and remote code execution attack

A flaw has been discovered where an attacker can include (view and potentially execute) files on the server.
The vulnerability comes from a portion of code where pages are redirected and loaded within phpMyAdmin, and an improper test for whitelisted pages.
An attacker must be authenticated, except in these situations:
  • $cfg['AllowArbitraryServer'] = true: attacker can specify any host he/she is already in control of, and execute arbitrary code on phpMyAdmin
  • $cfg['ServerDefault'] = 0: this bypasses the login and runs the vulnerable code without any authentication

Affected Versions:

phpMyAdmin 4.8.0 and 4.8.1 are affected.

Reference:

https://www.phpmyadmin.net/security/PMASA-2018-4/

Patch:

https://github.com/phpmyadmin/phpmyadmin/commit/7662d02939fb3cf6f0d9ec32ac664401dcfe7490


Related issues

Copied from Alpine Linux - Bug #9091: phpmyadmin: Multiple vulnerabilities (CVE-2018-12581, CVE-2018-12613)Closed2018-07-16

Associated revisions

Revision 28ad7409 (diff)
Added by Natanael Copa 6 months ago

community/phpmyadmin: security upgrade to 4.8.2 (CVE-2018-12581,CVE-2018-12613)

fixes #9093

History

#1 Updated by Alicha CH 6 months ago

  • Copied from Bug #9091: phpmyadmin: Multiple vulnerabilities (CVE-2018-12581, CVE-2018-12613) added

#2 Updated by Natanael Copa 6 months ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

#3 Updated by Alicha CH 6 months ago

  • Project changed from Alpine Security to Alpine Linux
  • Category set to Security
  • Status changed from Resolved to Closed
  • Security IDs deleted (CVE-2018-12581, CVE-2018-12613)

Also available in: Atom PDF